PHP

Ошибка "You are using a feature that requires cookie domain to be set but it is not set in your settings.php file"

Если вы настраиваете CKEditor + CKFinder на Drupal, то можете столкнуться с ошибкой "You are using a feature that requires $cookie_domain to be set, but it is not set in your settings.php". Возникает она из-за того, что в конфигурационном файле Друпала не была задана или была задана неправильно переменная $cookie_domain. О том, как решить эту проблему, читайте далее.

Обновление PHP на сервере CentOS 5.x

Недавно столкнулся с вопросом как обновить PHP с версии 5.3 до 5.4 на сервере CentOS 5.x. Пришлось искать решение в интернете, благо материалы есть.

Для начала следует определиться, а нужно ли вам обновлять PHP, ведь придется использовать не стандартный, а отдельный репозиторий. Ну и если решение принято, то необходимо удалить PHP, установленный на сервере в настоящее время. Затем добавить репозиторий, из которого будем скачивать новую версию интерпретатора. Потом установить новый PHP и, возможно, некоторые расширения.

Далее пара команд, которыми это всё проделывается.

Установка модуля CKEditor и настройка CKFinder на Drupal 7.

Многие переходят с Drupal 6 на седьмую версию. Кто-то ставит с нуля сразу семерку, как автор. И оказывается, что в сети относительно мало информации о том, как установить CKEditor + CKFinder и настроить CKFinder на Drupal 7. Не знаю, в чем причина. То ли большинство уже прожженные мастера друпала и им такая инструкция ни к чему, то ли еще просто слишком мало людей столкнулось с этой задачей. В любом случае, подходящую информацию я нашел только на англоязычном сайте.

Subscribe to RSS - PHP